Previo de WordPress 1.6 alpha 2

Hoy instalé el WordPress 1.6 alpha 2 en un servidor de prueba y les voy a compartir mi experiencia. Superficialmente es muy parecido al 1.5, los cambios más notables están en el área de escritura donde han implementado un editor WYSIWYG, vamos a verlo.

Instalación

El proceso de instalación es idéntico a la versión 1.5. Únicamente te pide nombre de la base de datos, usuario y password. Después te crea un usuario admin con un password aleatorio.

Dashboard

WriteEl “Dashboard” es similar al de WordPress 1.5, mantiene la misma estructura y sigue siendo azul pero más saturado. Los enlaces en la barra de navegación son los mismos — Dashboard, Write, Manage, Links, Presentation, Plugins, Users y Options.

Write

WriteEn la sección de “Write” es donde encontré el cambio más notable. Los desarrolladores de WordPress decidieron incluir un editor WYSIWYG (lo que ves es lo que obtienes), luego les cuento más sobre el editor.

A la derecha del editor tenemos las propiedades del post, que como ven se pueden colapsar y acomodar a nuestro gusto. Dentro de la caja de categorías ahora podemos agregar una categoría sin tener que ir a gestionar las categorías, solo escribimos el nombre de la categoría, hacemos click en el botón y la agrega sin necesidad de recargar la página, al puro estilo AJAX.

El editor WYSIWYG está basado en el TinyMCE, vayan a la página de muestras para que vean lo que se puede hacer con este editor. Intenten cambiar el tamaño de la imagen dentro del post, ¿no es eso increíble?

DashboardEl editor WYSIWYG puede ser deshabilitado en la página de opciones.

Temas

DashboardOtra novedad es que en la página de temas podemos ver en una imagen un previo del tema. Las imágenes de los temas deben ser proporcionadas por el diseñador.

Descubrí que WP 1.6 no es compatible con WP 1.5, hicieron algunos cambios en la estructura de la base de datos, muy pocos pero suficientes para impedir actualizar a 1.6 solo reescribiendo los archivos. Seguramente cuando lancen la versión final de WP 1.6 vendrá acompañado de un script para actualizar nuestro WordPress.

OJO No recomiendan utilizar 1.6 alpha2 por considerarlo inestable.

Para los que quieran un editor WYSIWYG en su WP 1.5 pueden instalar un plugin muy similar a lo que vendrá en WP 1.6.

Leer completa…